Boost logo

Boost Users :

Subject: [Boost-users] [Review] Type Traits Extension by Frederic Bron - Review summary and decision
From: Joel Falcou (joel.falcou_at_[hidden])
Date: 2011-03-26 12:57:27


Hello all,

Frederic Bron's type traits extension proposal review ended up last week.
In so far, we received SEVEN reviews which are all voting YES for the
inclusion
of Type Traits extension in Boost.

So the result is that the Type Traits Extension is ACCEPTED into Boost.

Suggestions include:

  - some clean-up in the implementation like "Renam[ing] the detail
classes inside the specific namespace without using number, i.e. with a
clear meaning. The use of tag, tag 2 could be renamed check_pass,
check_fail or something like that."
  - Sensibility on cv-ref qualifiers in traits call is important. This
is being addressed by Frederic.
  - Frederic is OK to keep the detection of void as a valid return type
by using some dont_check type as default.

  - small comprehensive example of some of the traits like a
"maybe_print function, which prints a value if the appropriate
operator<< ostream overload exists,
else prints "<NOT PRINTABLE>". [...] a small example like this would
show a practical use of the library, and how to make use of enable_if,
or some other overload method."

  - The main recurring suggestions found was the choice of name for the
operator traits with respect to the standard naming, naming in proto and
other boost libraries. This
topic is still hot and alive. An alternative to the naming scheme
consensus was proposed in the form of alias of commonly used operator
traits. This issue is I think beyond bikeshed-color argumentation and I
think it is a good point if Frederic could step up and provide a
definite and rationalized answer to this point. The current status is :
   * the namespace options is out casue the standard didnt choose this way;
   * Frederic and a few other seems to favor the proto naming scheme
(more or less the negate issue and the pre/post operator)
   * the question of a common prefix is still open
   * the std:: like naming seems limited as not all operators are there.

Thanks to all reviewers and people participating to the discussions.
Thanks to Frederic for his work.


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net