Boost logo

Boost Users :

Subject: [Boost-users] Issues with two versions of boost libs in same executable?
From: Magyar, Thomas J. CIV NAVAIR (thomas.magyar_at_[hidden])
Date: 2011-04-05 08:48:25

So I'm having an issue with running an executable which statically links in the boost thread and system libraries on a SUSE Linux 64-bit computer. The static libraries are from boost 1.35.0.

I also link with a 3rd party .so library. This library pulls in another version of the boost thread library in a .so, which is version 1.44.0.

Depending on how I run our program, I get a crash in this 3rd party libraries call stack when it looks like it is trying to create a boost thread. When I removed our code that uses the boost libraries, everything worked fine. When I remove the 3rd party library, everything works fine.

I'm not familiar with how programs work under this circumstance. Could this mixing of boost versions be a legitimate problem? Is the 3rd party library trying to call a boost function in our statically linked code under certain circumstances, causing the crash?



Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at