Boost logo

Boost Users :

Subject: Re: [Boost-users] Installing boost.mpi on Cray system
From: Ilja Honkonen (ilja.honkonen_at_[hidden])
Date: 2011-06-21 11:05:18

21.06.2011 17:35, khaled hamidouche kirjoitti:
> I'm trying to install boost and its MPI bindings on a Cray XE6 and this
> is what I get after adding using mpi ; to user-config.jam:
> MPI auto-detection failed: unknown wrapper compiler
> /opt/cray/xt-asyncpe/4.9/bin/CC
> or
> MPI auto-detection failed: unknown wrapper compiler mpic++

I ran into the same problem last year:

Since then I got some help from Cray (Paolo Palazzi and others), this is
what I currently use on a XT5 and Intel:

echo "using mpi : : <find-shared-library>mpich ;" >>
./tools/build/v2/user-config.jam &&

echo "using intel : : :
<linkflags>-L/opt/mpt/default/xt/mpich2-gnu/lib ;
" >> ./tools/build/v2/user-config.jam &&

./bjam --prefix=... toolset=intel &&

./bjam install --prefix=... toolset=intel


echo "using mpi : : <find-shared-library>mpich ;" >>
./tools/build/v2/user-config.jam &&

echo "using gcc : : :
<linkflags>-L/opt/mpt/default/xt/mpich2-gnu/lib ;"
>> ./tools/build/v2/user-config.jam &&

./bjam --prefix=... &&

./bjam install --prefix=...

toolset=pgi should work with PGI.

Substitute /opt/mpt/default/... with for example
/opt/cray/mpt/5.2.0/xt/seastar/mpich2-gnu/ if you use a newer version of

I also have the following in ~/bin/ (which is in $PATH) but it is
probably not required:
mpic++ -> /opt/cray/xt-asyncpe/3.3/bin/CC

Hmm, actually for intel the -L and -I should probably be
/opt/mpt/default/xt/mpich2-intel/... but mpich2-gnu seems to have worked
so far.


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at