Boost logo

Boost Users :

Subject: Re: [Boost-users] BGL: How to get add_edge work with adjacency_list graph
From: Jeremiah Willcock (jewillco_at_[hidden])
Date: 2011-09-26 10:50:35


On Mon, 26 Sep 2011, Christoph wrote:

>> The add_edge() function should be called unqualified; the compiler will
>> find the correct definition. In particular, it is not a member of any
>> class (static or non-static).
>
> Thank you very much for your answer. When i replace
>
> "Map::add_edge(u, v, map)"
>
> by
>
> "boost::add_edge(u, v, map)"
>
> it works fine.

You should really use "add_edge(u, v, map)" in case that function is moved
to a different namespace in the future (or for user-defined graph types
that are not in the boost namespace, if you care about those).

-- Jeremiah Willcock


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net