Boost logo

Boost Users :

Subject: Re: [Boost-users] msvc linker wants to prepend "lib" to library names
From: Nathan Currier (nathan.currier_at_[hidden])
Date: 2012-02-02 14:30:10

lib being added to the beginning of the library name represents linking
dynamically. In MS Visual Studio, you can change between Static and Dynamic
under Project / Properties / Configuration Properties / C/C++ / Code
Generation / Runtime Library. A setting of MD or MDd is Dynamic and MT or
MTd is Static, the appended 'd' representing debug capabilities. Try
swapping between the two types to see if it fixes the linking problem.

- - - - - - - - - - - -
*Nathan Currier*

On Thu, Feb 2, 2012 at 8:02 AM, Andy Falanga (afalanga) <afalanga_at_[hidden]
> wrote:

> Hi everyone,****
> ** **
> I’m working through an issue which no longer seems to be unique to me.
> I’ve found several instances of people having this same issue. As the
> subject suggests, I’m in a situation where the msvc linker is prepending
> “lib” to the referenced boost library (in this case, regex) for the
> project. However, the interesting thing is, it’s not happening for me,
> only for others on my team. On my dev box, the project builds just fine.
> To the best of my knowledge, I have pushed up all required changes (I added
> the need for regex with some changes I put in place) to the Team Foundation
> Server. However, when my colleagues checkout the latest revision of this
> new solution, they are unable to build because of this.****
> ** **
> The simple question is, why is this happening? I’d like to understand
> what’s going on rather than simply being told how to fix it. From the many
> hits I’ve looked through, I’ve tried a couple of things but they do not
> seem to fix the problem. I found a link that said the problem is because I
> needed to additionally link with comsupp.lib (I found an article on MS that
> instructs to link with comsuppw.lib or comsuppdw.lib instead) to which I
> tried, but that hasn’t fixed the issue. I found another that suggested I
> define the macro BOOST_ALL_DYN_LINK in the source code, but this hasn’t
> helped either.****
> ** **
> Our environment is that we’ve installed boost 1.47 via the installer from
> boost-pro. The solution has all appropriate directories mapped (include
> and library directories). Are there property settings in my project that I
> should look for? I’ve been able to glean that this problem has something
> to do with static vs. dynamic linking. Should I check in my linker options
> for something? I have done that extensively already, but I’m not a strong
> MS developer and could have easily missed something.****
> ** **
> ** **
> Thanks,****
> Andy****
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at