Boost logo

Boost Users :

Subject: Re: [Boost-users] Building boost fails with VS2017 (v15.5.2)
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2018-01-06 14:42:21


On 01/06/2018 07:29 AM, Christian Henning via Boost-users wrote:
> Thanks Joël, I have tried your suggestion but with no luck.
> When looking closer to the output I see:
> call
> "C:\Users\CHHENN~1\AppData\Local\Temp\b2_msvc_14.1_vcvarsx86_amd64_.cmd"
>> nul
> cl /Zm800 -nologo
> @"bin.v2\libs\atomic\build\msvc-14.1\debug\address-model-64\architecture-x86\link-static\threadapi-win32\threading-multi\lockpool.obj.rsp"
> 'cl' is not recognized as an internal or external command,
> This file "C:\Users\CHHENN~1\AppData\Local\Temp\b2_msvc_14.1_vcvarsx86_amd64_.cmd"
> is referencing an incorrect folder:
> C:\Program Files (x86)\Microsoft Visual
> Studio\2017\Community\VC\Tools\MSVC\14.11.25503\bin\HostX86\x64
> but the correct folder is:
> C:\Program Files (x86)\Microsoft Visual
> Studio\2017\Community\VC\Tools\MSVC\14.12.25827\bin\Hostx86\x64
> The question now is how to fix that?

  The script is out-dated. Delete it and let it
be regenerated. (Note: In develop the script is
generated under bin.v2 so a clean build will never
pick up an old script. I also tried to make it

In Christ,
Steven Watanabe

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at