On Thu, May 14, 2009 at 1:45 PM, Zeljko Vrba <zvrba@ifi.uio.no> wrote:
On Thu, May 14, 2009 at 01:38:35PM -0500, Robert Dailey wrote:
> Sorry to rush this, but I'm completely blocked until I can build boost with
> reasonable library names on Windows. Can anyone help me figure out what I
> need to do to get the library names generated without any mangling?
Sorry for jumping into the discussion, but I'm curious..  You probably do not
build boost every day, so why don't you just manually rename or copy the
resulting lib files to some sane names?

Because if I decide to use shared libraries, doing so will prevent the import libraries from finding their corresponding shared library. Not to mention that this is tedious to do. I would have to do this each time I upgrade boost.


I apologize, I must not be communicating with you in the same language. I thought this would be simple to explain. Let me try to explain this with as many details as I can just to make sure I'm clear. When I built boost 1.38 for Windows x86 using VS9, I used the following command line:

bjam --toolset=msvc --layout=system link=shared threading=multi release debug stage

When I did this, my library names looked like this (For the Boost.Filesystem library):


Everything worked just fine. The reason why I used --layout=system was so that the library names were more simplified and did not contain information like the version of boost used.

However, when I try the very same command line with Boost 1.39 I get the errors I posted earlier. I can't explain this any simpler than I am. I am merely a user of boost, I do not have the domain knowledge to delve into Boost.Build, nor do I want to learn it. My goal is to build boost the way I want, not to learn a new build system. I'm already a bit upset that this is turning out to be so complicated, I just want it to work like it is supposed to.

There is no documentation I have been able to find that discusses why this worked in 1.38 but breaks in 1.39 on Windows. My searching on Google has come up with very few results, and of those results the issue still isn't made very clear. No one has been able to explain to me, clearly, what exactly to do to get this to work. I'm not asking for much. What I'm asking should be one of the simplest questions to answer on this list. If I am still not being clear or if I am failing to provide certain information, please let me know.