after posting the below message, I ran in sequence:

bjam --clean debug release

./bootstrap.sh --with-libraries=all


./b2 --layout=tagged

./b2 --layout=tagged install

  but I still see only the -mt libraries in /usr/local/lib

Please let me know how I can fix this. thanks!

From: fin_engr@hotmail.com
To: boost-users@lists.boost.org
Subject: FW: boost -mt libraries in cygwin
Date: Sun, 25 Sep 2011 10:15:28 -0400


I just built and installed boost using the following on cygwin

./bootstrap.sh --with-libraries=chrono,date_time,exception,filesystem,graph,graph_parallel,iostreams,math,program_options,random,serialization,signals,system,test,thread,wave  link=static link=shared threading=single threading=multi

then I ran the below,
./b2  --layout=tagged

and the message indicated that it:

failed updating 2 targets and skipped 7 targets....

but I continued and ran

./b2  --layout=tagged install

however, I look in /usr/local/lib and I only have those libraries with suffix -mt

My programs are looking for the libraries without the -mt suffix.

Can you please let me know what I need to do to get those libraries.