Boost logo

Geometry :

Subject: [ggl] Point/Box in Box Test (Border Cases - 3D)
From: Adam Wulkiewicz (adam.wulkiewicz)
Date: 2011-07-09 02:59:29

Barend Gehrels wrote:
> It stays in namespace detail until there is complete agreement on the
> interface (parameter, strategy, function name), so maybe you will have
> to rename something in the future, but the functionality is there. I now
> believe that it is the best to adapt to PostGIS and Oracle here, they
> call it "coveredBy". See
> defining it as "Returns 1 (TRUE) if no point in Geometry A is outside
> GeometryB", which is what I described. So covered_by would be a
> convenient and (I think) intuitive name.

If there are some functions which gives almost the same results, users
may be confused. Then there are sentences in the documentation like the
one in postgis docs: "There are certain subtleties to ST_Contains and
ST_Within that are not intuitively obvious. For details check out
Subtleties of OGC Covers, Contains, Within" plus some external pages
describing these subtleties. I'd rather have one function with
parameters, preferably compile-time ones and eventually a version with
run-time parameters which calls compile-time version.


Geometry list run by mateusz at