Subject: Re: [geometry] one more variation to "transform"/"convert"/"for_each_point"
From: Bruno Lalande (bruno.lalande_at_[hidden])
Date: 2012-02-17 05:09:03
Yep, the range in question clearly follows the definition of a view (it's
light-weight, and accesses the points/segments lazily, by referring rather
than copying - for the segments views, I expect it to use a
Note that we could also very well have a name that doesn't reflect whether
it's a range or view:
Not sure if whether it's a view or a range should be exposed to the user...
And not sure if Boost has naming policy in this regard.
Geometry list run by mateusz at loskot.net