Boost logo

Geometry :

Subject: Re: [geometry] Dissolve in version 1.63
From: Johan Doré (jdh_at_[hidden])
Date: 2017-01-10 10:33:06

Dear Barend,

Thanks for the update. I completely understand and wait patiently.

Best regards


From: Geometry [mailto:geometry-bounces_at_[hidden]] On Behalf Of Barend Gehrels
Sent: Monday, January 9, 2017 17:54
To: Boost.Geometry library mailing list <geometry_at_[hidden]>
Subject: Re: [geometry] Dissolve in version 1.63

Hi Johan,

Op 8-1-2017 om 18:19 schreef Johan Doré:
Dear Boost Geometry

I thought I should give it a try in 1.63 to see if some of your other contributions helped on the below described dissolve problem

Unfortunately 1.63 produces the same error.

Is there anything I can do to propel a solution for this, keeping in mind that I am far from being a boost::geometry programmer

Sorry for my delays in answers. Yes, indeed, the errors are not fixed. Please note (but you know) that dissolve is an extension and not officially maintained. Due to works in underlying code, and some changes in underlying concepts, the algorithm does not work anymore for some cases that were supported before.

We're working on validity of geometries, and after that the rescaling (which is used internally for overlay operations) will be adapted or removed completely. That might also cause some differences. After that I will try to fix dissolve again in the state it was before (and maybe even better, in the end it should once be released). But doing it now is not possible.

Sorry for the inconvenience.

Best regards, Barend

From: Geometry [mailto:geometry-bounces_at_[hidden]] On Behalf Of Johan Doré
Sent: Sunday, September 18, 2016 21:30
To: Boost.Geometry library mailing list <geometry_at_[hidden]<mailto:geometry_at_[hidden]>>
Subject: [geometry] Dissolve in version 1.61

Dear Boost::Geometry

I am sorry that it took so long but I now tried the latest "develop" branch available on GitHub of the geometry library.

Maybe I am doing something wrong, but a lot of my test cases around the boost::geometry::dissolve function seem to fail now.

E.g if I try this polygon<point_xy<float>> Input containing the points:
       0.0000000000000000 1.0000000000000000
       1.0000000000000000 0.0000000000000000
       1.0000000000000000 1.0000000000000000
       0.0000000000000000 0.0000000000000000
       0.0000000000000000 1.0000000000000000

The following call to dissolve:
  multi_polygon<polygon<point_xy<float>>> Dissolved;
  boost::geometry::dissolve(Input, Dissolved);

just returns an empty Dissolved multi_polygon

Is there anything which I can be doing wrong?

Best regards, and as always thanks for your great work


Geometry list run by mateusz at