Boost logo

Proto :

Subject: Re: [proto] Visitor Design Pattern
From: Eric Niebler (eric_at_[hidden])
Date: 2010-10-25 00:39:01

On 10/24/2010 8:32 PM, Joel de Guzman wrote:
> On 10/25/2010 8:49 AM, Eric Niebler wrote:
>> Like "visitor", "actor" comes with lots of baggage that we don't want:
>> Besides, as these things define algorithms, a name that's a verb would
>> be better (std::transform, std::accumulate, etc. are verbs).
> That's a totally different synonym. The actor that I meant is
> connected to the meaning of "semantic action" and you are using
> action/actions anyway (as well as grammars and rules). It's the
> same domain.

Oh. I didn't make the connection between "actor" and "semantic action".
For me, "actor" is so strongly evocative of concurrent programming that
I can't read it any other way.

>> How about "evaluate":
>> proto::evaluate<char_terminal, my_actions>()(a);
> Hmmm... :P

You're not loving that, either, are you? evaluate_with? with_actions?
<shrug> They're all terrible. I won't bother the list any more with
naming issues. Thanks to everybody who contributed ideas to the design
of the-yet-to-be-named-thingie. Especial Thomas.

Eric Niebler
BoostPro Computing

Proto list run by eric at