Subject: Re: [proto] Extendin proto::switch_
From: Joel Falcou (joel.falcou_at_[hidden])
Date: 2011-08-29 12:14:46
Le 29/08/2011 17:33, Eric Niebler a écrit :
> Good. Obviously, this needs to be called switch_ instead of select_.
Sure I was testing the water inside nt2 first
> There needs to be an appropriate default for the Transform parameter,
> something like tag_of<_>(). There should also be a specialization of
> switch_ when the transform is tag_of<_>() to make it as efficient as the
> current switch_ (but it should be backward-compatible without the
> specialization -- test this!). And of course docs and tests.
> No need to replace the internal use of when, but you can access when's
> nested impl template directly instead of using result_of's needlessly
> complicated machinery. See the implementation of if_.
OK great then :)
I have to come back from a conference and I'll start pushing this to
trunk as soon as it looks pretty.
Proto list run by eric at boostpro.com