Boost logo

Ublas :

From: Sorkin Dima (dsorkin_at_[hidden])
Date: 2007-08-04 16:41:32


Hi.
  I use a lapack ormqr() and geqrf() with
ublas of boost 1.33.1 and get the following error

----------
boost/numeric/bindings/traits/ublas_matrix.hpp:78:
error: 'size_M' is not a member of
     'boost::numeric::ublas::column_major'
----------

the 'column_major' has instead the size1(sz1,sz2) and size2(sz1,sz2)
functions. I remember the discussion was to replace these with
size_M and size_m for clarity.

Question:
1. To which version of ublas should I upgrade to get those fixed
    (boost release is preferable, if not - CVS/SVN ? )
2. If I decide to fix those manually: which one maps to which
    and what is their meaning (which one denotes dimension
    that lies continuously in memory) ?

Thank you.
Regards,
  Dima.