Boost logo

Ublas :

Subject: Re: [ublas] [bindings] Workspaces
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2008-12-17 06:13:08

Thomas Klimpel wrote:
> The lapack bindings use
> "boost::numeric::bindings::traits::detail::array<T>" for minimal_workspace
> and optimal_workspace, but the user is not required to do the same. It is
> perfectly valid to use a "std::vector<T>" or a
> "boost::numeric::ublas::vector<T>" or any other container satisfying the
> vector traits requirements for providing workspace. So I think
> "get_array_of" is a misleading name.

Ok, I guess I was following the lapack naming convention. I was thinking,
e.g., workspace2 = { array1, array2 } with array being of any array type.
Vector would be another logical name. Alternatives could be
get_workspace_of<>, or get_workspace_array_of<>? Or do you have other

> What do you mean by "temporary arrays"? The temporary references to the
> arrays? Or the temporary arrays allocated by the bindings in case of
> minimal_workspace or optimal_workspace? Or the vector storage container
> provided by the user in case of user provided workspace?

I meant temporary workspace arrays, instantiated for the minimal and optimal
cases. I though it would be clean to wrap these ones in a workspace-struct
and pass them on as if they were defined by a user.