Boost logo

Ublas :

Subject: Re: [ublas] [bindings][traits] is_vector, is_matrix
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2009-03-11 03:56:26

Karl Meerbergen wrote:

> In fact, what I wanted to say is that it might perhaps be better to stay
> in line with
> and have some meta function of the style
> is< BindableVector, V >
> is< BindableMatrix, V >
> is< BindableSparseMatrix, V >
> or alternatively
> BindableVector<V>
> BindableMatrix<V>
> Karl

Thanks for the reference. For naming of these traits, I was actually looking
at Boost.Type_traits, which would yield expressions like


is this more in line with what you mean?