Boost logo

Ublas :

Subject: Re: [ublas] [bindings][traits] is_vector, is_matrix
From: Chris Rodgers (christopher.rodgers_at_[hidden])
Date: 2009-03-11 06:10:55

On 11/03/2009 09:16, Rutger ter Borg wrote:
> Karl Meerbergen wrote:
>> Rutger,
>> I am not always in favour of common names for different operations on
>> the bindings level.
>> Similarly, one could argue whether it is a good idea to have a function
>> eig(), e.g. for unsymmetric and symmetric matrices, since their
>> interface looks the same, but it is not the same (think of complex or
>> real eigenvalues). using the same names for everything suggests the user
>> not to think any longer about what he is doing (like in matlab).

My vote would be to collapse things into short names e.g. eig(), solve()
as much as it is possible to distinguish the different forms based on
the types of the input arguments.

As a backup, it would be good to have some low-level names if you know
exactly what method you wish to call.

I think that this would go a long way towards making C++ linear algebra
more user-friendly.