Subject: Re: [ublas] [bindings] naming for sparse matrices
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2010-02-15 03:23:03
Rutger ter Borg wrote:
> Let's get rid of the index<> tag first, it's too confusing with the sparse
> index stuff. What about renaming the index<> tag to dim<>? There are also
> some meta-funcs in index.hpp which should be renamed. I would add two
> static functions to compressed containers,
I would like to apply this one, but I don't think dim<> is the right name.
Annoying, it's a kind of an index of the index. Right now, it is
index // == static 1, 2, etc. equals the N in sizeN.
index_major // == index<N>, N depends on data_order
but this naming conflicts with providing an array of indices. What about...
or index_tuple, entry, entry_at, or...?
Votes please :-)