Subject: Re: [ublas] Numeric traits for ublas bounded_vector and matrix
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2010-02-23 03:06:13
Jesse Perla wrote:
> Since ublas doesn't make the distinction between static size vs.
> allocation, perhaps the better names are:
> has_static_allocation<> and static_allocation_size<>
Yes, but allocations done by ublas (e.g., bounded_array) also have dynamic
Isn't some of the information you're after identical to
has_static_stride<T>? I.e., I guess has_static_stride<T> is identical to
has_bounded_linear_array<T> or something like that.
Then, you can misuse containers having static strides all you want :-) ...
but I would recommend doing stuff correct/strict the first time. Perhaps
proposing a static_matrix and static_vector to ublas would be the way (if
you want to stick to boost/ublas for your container needs)?