Boost logo

Ublas :

Subject: Re: [ublas] [bindings] How do I call the new gees? Why is it different from the old one?
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2010-04-19 10:59:26


Paul Leopardi wrote:

> Hi all,
> I'm now trying to use the current bindings and finding it much harder to
> use than the V1 bindings. In particular, how should I be calling the new
> gees in the following piece of code (from glucat/matrix_imp.h)?
>
> #if defined(_GLUCAT_USE_BINDINGS_V1)
> #include <boost/numeric/bindings/lapack/workspace.hpp>
> #include <boost/numeric/bindings/lapack/gees.hpp>
> #include <boost/numeric/bindings/traits/ublas_matrix.hpp>
> #endif
> #if defined(_GLUCAT_USE_BINDINGS)
> #include <boost/numeric/bindings/lapack/workspace.hpp>
> #include <boost/numeric/bindings/lapack/driver/gees.hpp>
> #endif
>

I will look into more detail later, but at this point you forgot to include
support for UBLAS matrices. Workspace is a dependency, so will be included
automatically.

#if defined(_GLUCAT_USE_BINDINGS)
#include <boost/numeric/bindings/lapack/driver/gees.hpp>
#include <boost/numeric/bindings/ublas/matrix.hpp>
#endif

Cheers,

Rutger