Subject: Re: [ublas] [bindings] How do I call the new gees? Why is it different from the old one?
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2010-04-19 12:20:54
Paul Leopardi wrote:
> Yes, you are right. I now get a different error message, about
> property_map. I'm trying to use Boost 1.41.0. Should this version of Boost
> work with the current bindings?
> Best, Paul
If the compiler complains about property maps, it's fairly safe to say you
are missing an include. The type you forgot to include is mentioned by the
> error: no type named âproperty_mapâ in âstruct
> boost::numeric::ublas::basic_column_major<long unsigned int, long int>,
> boost::numeric::ublas::unbounded_array<double, std::allocator<double> > >,
In your case, most likely you forgot to
somewhere. FYI, the old-style of including "traits/ublas_matrix.hpp" has
been replaced by "ublas/matrix.hpp". Also see my other reply to your