Boost logo

Ublas :

Subject: Re: [ublas] [bindings] How do I call the new gees? Why is it different from the old one?
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2010-11-22 04:26:28


On 11/21/2010 04:50 PM, Thomas Klimpel wrote:
> The method described in the paper seems reasonable simple, but I decided to implement the "straightforward" recursive method with O(n) time and O(log(n)) (stack) space first. The attached file contains both a non-optimized implementation (which takes O(nlog(n)) time due to missing optimizations, but makes it obvious how the method works in principle), and an optimized implementation. As the O(log(n)) (stack) space is normally not considered a drawback for quicksort, I think this implementation should be good enough for our purposes. However, I may still implement the method from the paper one day in the distant future, and benchmark both methods against each other. But before I do this, I will first try to update geev and gees to offer functionality similar to what was available in bindings-v1, with the main difference being that explicit memory allocation is avoided.
>
> Regards,
> Thomas
>

Great! Ideas on where/how to put an overloaded execution path for this?
Perhaps as an extra pair of free functions, because they already contain
an enable_if instantiation condition? In that scenario, we also leave
intact the original interface/overload.

Cheers,

Rutger