Boost logo

Boost :

From: Moore, Paul (paul.moore_at_[hidden])
Date: 2001-11-01 07:40:40


From: helmut.zeisel_at_[hidden]
> The header ratioal.hpp defines rational_cast
> to convert a rational type to a floatig point type.
>
> Do we need a special name for that purpose
> or might it be more consistent to
> use an overload of numeric_cast instead of rational_cast?

According to the documentation, numeric_cast is to act like static_cast, but
to detect loss of numeric range. Specifically, "An exception is thrown when
a runtime value-preservation check fails." The rational_cast function
doesn't do anything like this, so I don't think it's a valid variant of
numeric_cast.

And besides, the numeric_cast code looks scary, compared to rational_cast. I
don't relish trying to integrate the code (for no real benefit).

Paul.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk