Boost logo

Boost :

From: Zach Laine (whatwasthataddress_at_[hidden])
Date: 2007-08-14 09:18:57


On 8/13/07, Eric Niebler <eric_at_[hidden]> wrote:
>
> > The issues Steven has raised wrt the use of commit(). If there really
> > are no efficiency gains from the commit() technique, it is unidiomatic
> > enough that I think it should go away.
>
> Have you followed recent messages in that thread? I was able to explain
> the rationale for the inserters in a way that made sense to Steven. This
> is the key message:
>
> http://lists.boost.org/Archives/boost/2007/08/125963.php

Yes, but rereading that one indicates that I may have misunderstood
some things. Is it the case that the ordered_inserter/commit() design
is an optimization for the general case of sequence insertion? If so,
I question whether the user should be forced to use this when there is
an efficient iterator-based technique that works as well. In fact,
many people will choose an iterator-based insertion technique even if
it's less efficient, when the efficiency gains are insignificant,
simply for the readability and maintenance benefits.

> > coarse_grain() and fine_grain() need to be customizable.
> > I would still like to see a int/floating point mapping from sample
> > space to index space for dense_series<> that you alluded to in a
> > previous email.
>
> Are you referring to an interpolating facade? Yes, that is a must have.

That would be great to have too. I was refering to the use of
arbitrary up-sample and down-sample functors in these functions.

Zach Laine


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk