Boost logo

Boost :

From: Matus Chochlik (chochlik_at_[hidden])
Date: 2008-04-26 08:54:07


Hi,

I'm interested too,

On Sat, Apr 26, 2008 at 2:09 PM, Marco Costalba <mcostalba_at_[hidden]> wrote:
> On Sat, Apr 26, 2008 at 12:37 PM, Joseph Wu <josephclwu_at_[hidden]> wrote:
> > Marco Costalba wrote:
> >
> > > If there is interest I can improve documentation and examples.
> >
> > I am definitely interested. I think it should be submitted for review.
> >
> > Some comments:
> >
> > 1. Does "reset" sound like a better name for "unset"?
> >
>
> boost::function uses clear(), should I use the same API for consistency?
>

I'd suggest two overloads:

clear<signature>() //for resetting the given signature and
clear(); //for resetting everything

>
> > 2. How about providing a get<signature> method returning ref to the
> > underlying boost::function object.
>
> Yes, I'll add it.
>
>
> Thanks for your comments
> Marco
>
> _______________________________________________
> Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
>

-- 
________________
::matus_chochlik

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk