Boost logo

Boost :

Subject: Re: [boost] boost.org Source-Code, Concepts & Idioms.
From: John Bytheway (jbytheway+boost_at_[hidden])
Date: 2008-10-15 04:59:04


Steven Watanabe wrote:
> Since the point is to make the code more readable,
> if we do any macro expansion for instance:
>
> #define SOME_MACRO(...) \
> template<class T> \
> class C { \
> /*stuff*/ \
> };
>
> SOME_MACRO(x, y, z)
>
> We don't want this all to end up on one line.

Perhaps run everything through a code beautifier after the
pseudo-preprocessing step?

Still, I'd have thought that macros like the above would usually be the
sort that would better not be expanded.

John Bytheway


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk