Subject: Re: [boost] [Review] [ITL] ITL formal review results
From: Joachim Faulhaber (afojgo_at_[hidden])
Date: 2010-04-19 09:50:32
2010/4/18 Paul A. Bristow <pbristow_at_[hidden]>:
>> -----Original Message-----
>> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of Hartmut Kaiser
>> Sent: Sunday, April 18, 2010 3:21 PM
>> To: boost_at_[hidden]; boost-users_at_[hidden]; boost-announce_at_[hidden]
>> Subject: [boost] [Review] [ITL] ITL formal review results
>> Last but not least people suggested to change the name of the library as
>> having the word template in the name does not carry any useful information.
>> Joachim already agreed to this.
> But did I miss discussion (or a conclusion) about what it *should* be called?
> We already have Boost.Interval which handles interval arithmetic, so it can't be that.
> So is this going to be called Boost.Intervals (sniffs ;-) or what?
There has been a discussion with a number of more or less appropriate
names or acronyms e.g.
coi containers of intervals
caci compact associative conainers of intervals
compass compact associative containers
Currently I tend to use the name that has been used for the objects of
the library already by various people including myself because it is
kind of "natural":
Boost.IntervalContainer (library name)
Because I hate long namespace identifiers, I think I will use a kind
of standard namespace alias
namespace icl = boost::interval_container;
so that 'itl' can be replaced by 'icl' without spoiling the current
Boost list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk