Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2023-12-02 14:30:04


Andrey Semashev wrote:
> If typing [&] is a problem, you could just
>
> #define SCOPE_GUARD BOOST_SCOPE_FINAL [&]
>
> and use that. Personally, I have no problem with the capture list, and
> quite often I actually use capture lists more elaborate than [&].

I _think_ that it might be possible to make the capture list optional
by using

BOOST_SCOPE_FINAL
{
};

and

BOOST_SCOPE_FINAL(&)
{
};

but I'm not 100% sure.

(And maybe rename it to BOOST_SCOPE_DEFER.)


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk