Boost logo

Boost :

From: Valentin Bonnard (Bonnard.V_at_[hidden])
Date: 1999-06-11 08:11:01

Beman Dawes wrote:

[ Messy adaptators naming conventions ]

> Functionality Boost Name SGI STL's Name
> f(g(value)) compose11 compose1
> f(g(value),h(value)) compose21 compose2
> f(g(value1),h(value2)) compose22
> f(g(value1,value2)) compose12
> f(g()) compose10

All this mess IMHO leads to:

1) almost unreadable code

2) reduced use of functional programming in C++

I think the only clear solution is to write something

(lambda (f g h) (lambda (x) (f (g x) (h x))))

in Lisp/Scheme style or

(fun f g h x -> f (g x) (h x))

in ML/Caml style.

I think it's _way_ more readable than a bunch
of combinators.

And of course, it isn't on topic for this list, as
support for such things would require a language
extension. I just wanted to see if this kind of idea
got some support here.

Valentin Bonnard
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at