Boost logo

Boost :

From: Beman Dawes (beman_at_[hidden])
Date: 1999-06-11 10:15:10

At 03:11 PM 6/11/99 +0200, Valentin Bonnard wrote:

>[ Messy adaptators naming conventions ]
>> Functionality Boost Name SGI STL's Name
>> f(g(value)) compose11 compose1
>> f(g(value),h(value)) compose21 compose2
>> f(g(value1),h(value2)) compose22
>> f(g(value1,value2)) compose12
>> f(g()) compose10
>All this mess IMHO leads to:
>1) almost unreadable code
> ...

Agreed. See if you can come up with a better approach to functional
programmming in C++ without changing the language. Who knows, you
might become famous and get your name in lights!


------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at