Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 1999-06-15 01:52:53

Sean A Corfield wrote:

> On Sunday, June 13, 1999 5:20 PM, Nicolai Josuttis
> [SMTP:nicolai.josuttis_at_[hidden]] wrote:
> > Sean, Valentin, I agree, but the question is not whether they are
> > good names, the question is, which are better names?
> ...
> > The problem with inject_compose, distr_compose, etc. was
> > that a normal programmer (who isn't familiar with FP) has no
> > idea what they mean but he has to learn several names.
> I raised this issue on accu-general (a C/C++ programmers mailing list) and
> they universally disapproved on the numerical encoding, preferring something
> 'English'...
> > Make constructive criticism please and choose better names.
> I did. I already proposed alternative names - back in Santa Cruz.

As I wrote above...

We simply (:-) have to find names that satisfy both requirements
 - self-explaining / intuitiuve
 - english
(I'd really like to)


------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at