Boost logo

Boost :

From: Sean A Corfield (sean_at_[hidden])
Date: 1999-06-14 04:07:32

On Sunday, June 13, 1999 5:20 PM, Nicolai Josuttis
[SMTP:nicolai.josuttis_at_[hidden]] wrote:
> Sean, Valentin, I agree, but the question is not whether they are
> good names, the question is, which are better names?
> The problem with inject_compose, distr_compose, etc. was
> that a normal programmer (who isn't familiar with FP) has no
> idea what they mean but he has to learn several names.

I raised this issue on accu-general (a C/C++ programmers mailing list) and
they universally disapproved on the numerical encoding, preferring something

> Make constructive criticism please and choose better names.

I did. I already proposed alternative names - back in Santa Cruz.

Sean A Corfield                            fax:+441252654077
Technical Director                      tel/sms:+44385758805
Object Consultancy Services Ltd
"If you're not annoying somebody, you're not really alive."
                                           - Margaret Atwood
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at