Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 1999-06-18 04:19:16

It seems we have worked out a new naming scheme for
the compose function adapters and everybody can
live with it or even likes it.
This is the scheme like compose_f_gx_hy.

I have send a new version of the compose stuff
that reflects this scheme to Beman so that we soon will
have an according update on the Web
(you can find it immediately at

For the question of "nonary_function" "nullary_function",
"niladic_function", "voidary_function", ...
it seems we get more and more suggestions.
So, for the moment I stay with "nonary_function".

Thanks all and best regards

Nicolai M. Josuttis
Solutions in Time
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at