Boost logo

Boost :

From: Kevlin Henney (Kevlin.Henney_at_[hidden])
Date: 1999-06-18 05:46:26

I agree that whatever else might be said, nonary_function is basically
wrong. However, leaving it in there to remind ourselves that a better name
is required has the ring of "we'll come back and fix it / do it properly
later". IME, this is said so often on software development projects that,
as a phrase, it deserves its own header file... and I think we know what
normally happens to code that will "get fixed later"...


Nathan Myers <ncm_at_[hidden]> on 18/06/99 10:44:20

Please respond to boost_at_[hidden]

To: boost_at_[hidden]
cc: (bcc: Kevlin Henney/QA Training Ltd)
Subject: [boost] Re: result of compose discussion

> For the question of "nonary_function" "nullary_function",
> "niladic_function", "voidary_function", ...
> it seems we get more and more suggestions.
> So, for the moment I stay with "nonary_function".

"Nonary" is abominable, but should remain as a goad until somebody
comes up with a good reason to favor one among the others. What's
wrong with "nonary"? First, it implies nine arguments.

Of the suggestions I have seen, niladic or nullary seem best.

Nathan Myers

eGroups now offers FREE email newsletters!, RollingStone, Travelocity, and more

------------------------------------------------------------------------ home: - Simplifying group communications

Sign-up Now! home: - Simplifying group communications

------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at