Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 1999-06-18 20:07:46

> names like one_arg_function, two_arg_function, and so on

This is the best one I've heard so far, and I don't think it can be improved
upon. I don't care about compatibility with the names unary_function and
binary_function much, since they're so poorly extensible. Unary and binary
really do refer to operator categories (see APL) and don't translate well to
generalized functions anyway.

If anyone thinks these names are too long (I don't) I'd be willing to fall
back on no_arg_fun, one_arg_fun, two_arg_fun, etc. (like mem_fun), but I
think that's unneccessary.


------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at