Boost logo

Boost :

From: Thomas Plum (tplum_at_[hidden])
Date: 1999-06-18 22:24:15

At 09:07 PM 6/18/99 -0400, you wrote:
>> names like one_arg_function, two_arg_function, and so on
>This is the best one I've heard so far, and I don't think it can be improved

Sounds like a challenge to me :-) !

IMHO the proposal that_ used digits had one "improved" feature. So how
about fun_0_arg, fun_1_arg, fun_2_arg etc?

Consider how the names sort in an index etc?

> I don't care about compatibility with the names unary_function and
>binary_function much, since they're so poorly extensible. Unary and binary
>really do refer to operator categories (see APL) and don't translate well to
>generalized functions anyway.
>If anyone thinks these names are too long (I don't) I'd be willing to fall
>back on no_arg_fun, one_arg_fun, two_arg_fun, etc. (like mem_fun), but I
>think that's unneccessary.


Thomas Plum Plum Hall Inc, 3 Waihona Box 44610, Kamuela HI 96743 USA
tplum_at_[hidden] TEL +1-808-882-1255 FAX +1-808-882-1556

------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at