Boost logo

Boost :

From: postmast.root.admi.gov_at_[hidden]
Date: 1999-09-02 08:39:27

Beman Dawes wrote:
> I will remove the boost/cast.hpp asserts,

Sounds like me with my libraries, before things stabilize :-)

> except for the non-throwing
> version of polymorpic_cast where the assert is critical, and will
> document the potential ODR problem there. I will also revert the
> name for that flavor to "safe_downcast". Thus it becomes exactly
> what you proposed two months ago. I suppose people will argue about
> the name, and thats okay, but let's move on.

I thought "safe_downcast" was spelled "dynamic_cast". Seems about as
safe as static_cast, only it happens to be checked during debugging
(only). Safe to me implies what dynamic_cast provides, and nothing
less. Perhaps debug_static_cast (or something along those lines) would
be clearer?

Boost list run by bdawes at, gregod at, cpdaniel at, john at