Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-02 09:54:12

> As I got no feedback so far:
> Did anybody look at it and is anybody interested?

I didn't look, but not because it isn't important. I have just always
assumed that something like this would arrive one day!

> However, I got some indirect feedback due to feeback to
> my book.
> It seems, that also Matt mentioned such a class in his book.
> This class is called "block".
> He implementes the class as POD (making the internal array public),
> so that the following is
> possible:
> carray<int,6> a = { 1, 2, 3, 4, 5, 6 }

can you still do that initialization with
carray<non_POD_type, 6> a = { non_POD_type(), non_POD_type() }?

If not, does it matter that you can't?

> This seems to be an important improvement.
> In addition, he introduces op==, op<, swap(), and reverse iterators.
> So, I will present a new version
> (in case, anybody is interested).
> However, one question remains:
> - Which name should we take?
> c_array, carray, block?
> Is one of these name used in a library alreay?

I prefer 'raw_array'. It's too hard to guess what the 'c' stands for and
'block' is downright un-descriptive.


Boost list run by bdawes at, gregod at, cpdaniel at, john at