Boost logo

Boost :

From: Gabriel Dos Reis (Gabriel.Dos-Reis_at_[hidden])
Date: 2000-01-02 14:33:34

Nicolai Josuttis <nicolai.josuttis_at_[hidden]> writes:

Hi Nico,

| As I got no feedback so far:
| Did anybody look at it and is anybody interested?

Or wasn't anybody being on holidays? :-)

| However, I got some indirect feedback due to feeback to
| my book.
| It seems, that also Matt mentioned such a class in his book.
| This class is called "block".
| He implementes the class as POD (making the internal array public),
| so that the following is
| possible:
| carray<int,6> a = { 1, 2, 3, 4, 5, 6 }
| This seems to be an important improvement.
| In addition, he introduces op==, op<, swap(), and reverse iterators.
| So, I will present a new version
| (in case, anybody is interested).
| However, one question remains:
| - Which name should we take?
| c_array, carray, block?
| Is one of these name used in a library alreay?

As Greg proposed, why not 'array'?


-- Gaby

Boost list run by bdawes at, gregod at, cpdaniel at, john at