Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-05 08:25:44


> The code was completely redesigned, and the 'size' class now renamed to
> 'delta'. They still have no documentation, is it a proper time to start to
> work on it? I'll be glad to hear any feedback about this new version of
> code - now it's much more acceptable (from my opinion ;).
>

Just quickly perusing:

    bool contains( const point_type& p ) const {
      return !( p.x() < left() || p.x() >= right()
              || p.y() < top() || p.y() >= bottom()
              );
    }

What is wrong with:

    bool contains( const point_type& p ) const {
      return p.x() >= left() && p.x() < right()
              && p.y() >= top() && p.y() < bottom();
    }

??


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk