Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-01-09 12:58:44

Dave Abrahams writes:
> Jeremy writ:
> >
> > Right, I was already thinking of the name ptr_array as a replacement :)
> That sounds like an array of pointers to me. array_ptr sounds like a pointer
> to an array, which is what this class wraps. Not perfect, but closer, I
> think.


> > How about "Collection"?
> Great. Now who will write the document which defines the concept? We ought
> to keep it broad enough to be able to encompass proxy containers as
> discussed earlier in this forum. Also, I expect we'll need a few refinements
> (e.g. immutable, reversible...).

I'll volunteer unless you are itching to do it :)

> P.S. I think "reversible_container_helper" should probably be
> "reversed_collection" or something. It doesn't help make the base container
> reversible after all; that's a property of the base container.




Boost list run by bdawes at, gregod at, cpdaniel at, john at