Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-01-15 15:35:31

I agree, just "Queue" would not be a good name.

How did you all feel about using the name "GeneralizedQueue", where
the "Generalized" part is meant to mean that it can be things other
than FIFO.

Andy Glew writes:
> > > "queue" means ordered extracts. LIFO if nothing else;
> > > or "priority_queue". No guarantees on internal order.
> >
> > Having LIFO as the "default" ordering of a queue disturbs me. Where I come
> > from, Queues are normally FIFO, and Stacks are LIFO.
> Sorry. mind-o.
> Queues are FIFO, stacks are LIFO in my world too.

Boost list run by bdawes at, gregod at, cpdaniel at, john at