Boost logo

Boost :

From: Andy Glew (glew_at_[hidden])
Date: 2000-01-15 17:04:13


> I agree, just "Queue" would not be a good name.
>
> How did you all feel about using the name "GeneralizedQueue", where
> the "Generalized" part is meant to mean that it can be things other
> than FIFO.

(1) IHateMixedCase and prefer_underscore_separation.
Sorry, religious topic, although shared_ptr>T> and auto_ptr<T>
have established IMHO the right precedent. ;-}

(2) I'm uncomfortable with "Generalized Queue", since there
is a subfield of queueing theory whose name is roughly similar.
Your "generalized queue" has little to do with a G/1/1 queue,
where "G" stands for a "general" distribution, but it's still
confusing.

This is a minor complaint. I could live with GeneralizedQueue.
Or the slightly shorter generic_queue.

(3) Why not "buffer"?

"Buffer" has long standing use in computer science, as something
that holds things for a while, but not permanently.

"Buffer" has no ordering connotations for me.
    Historically, IBM in the 1960s used "buffer" for a "FIFO queue",
but the Berkeley terminology seems to have taken over.

    Moreover, some of the earliest data structure references I have
seen say "pushdown buffer" or "stack buffer" for what we now
call a stack, and "FIFO buffer" or "queue buffer" for what we now
call a plain old queue.

I.e.

Queue = FIFO buffer
Stack = LIFO buffer
Priority Queue = buffer with some priority rule...


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk