Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-17 22:42:04

> The rational behind both MemberIterator and PipeIterator efforts is to
> avoid creating temporary storage and ugly adaptor classes. The
> "generic" algorithms often expect their input (or make output) as
> iterator ranges. These concepts help to provide such iterator
> ranges in cheap and non-intrusive way.
> What do you think?

I like the first one a lot if you call it member_iterator ;)
I've often wanted something like this. It's especially good for maps, where
the value type is a pair (first, second).

If I understand the second ones, they make input iterators and output
iterators out of function objects, right? They might be better named
input_iterator_adaptor and output_iterator_adaptor or some such.


Boost list run by bdawes at, gregod at, cpdaniel at, john at