Boost logo

Boost :

From: Andrei Tovtchigretchko (andrey_at_[hidden])
Date: 2000-01-18 21:28:16

Dave Abrahams wrote:
> I like the first one a lot if you call it member_iterator ;)

Sure. Iterator can be named some "member_iterator_t", and helper function -
like you suggested, since the user normally calls the helper function.

> If I understand the second ones, they make input iterators and output
> iterators out of function objects, right? They might be better named
> input_iterator_adaptor and output_iterator_adaptor or some such.

Maybe, "inp_iterator_adaptor" and "out_iterator_adaptor"
can save some typing. Anyway, if there is "shared_ptr" and not
"shared_pointer", why not establish "iter" as an abbreviation for


Boost list run by bdawes at, gregod at, cpdaniel at, john at