From: Darin Adler (darin_at_[hidden])
Date: 2000-02-06 17:18:05
> Which fits with scoped_ptr. Perhaps just scoped_value would do?
scoped_value is my favorite name so far. Runners up are scoped_value_changer
> Maybe these are two separate, useful classes. I can definitely see the use
> for auto_restore. It expresses something quite different, and though
> arguably less flexible, possibly more generally useful.
I agree that set_on_exit could also be useful and that scoped_value is less
flexible than set_on_exit. I'd prefer not to use a verb for a type name, so
I would not use the name set_on_exit (2nd name search needed?).
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk