Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-02-06 17:29:30

on 2/6/00 4:06 PM, Aleksey Gurtovoy at alexy_at_[hidden] wrote:

> I thought about the issue a little, and I came to a conclusion that
> 'make_point' probably would be a better choice. 'operator <<' gives us
> nothing besides a syntactic sugar, and even this 'sugar' has a questionable
> quality. On the other hand 'make_point' has an obvious analogy with
> 'std::make_pair' and you don't need to describe to anybody what exactly it
> does and how he must use it.. I love to invent cute syntactical expressions
> :), but it seems this one doesn't fit to my notion of 'cute'...

You're no doubt correct. Of course, it doesn't make much sense to have a
function called boost::geometry2d::make_point converting _from_
boost::geometry2d::point _to_ something else.

I was thinking something like boost::explicit_cast<> could be made to work.
Do we really have a function called boost::implicit_cast<>? That's an
oxymoron if I've ever met one!


Boost list run by bdawes at, gregod at, cpdaniel at, john at