Boost logo

Boost :

From: John Maddock (John_Maddock_at_[hidden])
Date: 2000-02-19 06:54:51


>However, wrapping this in some template specialization hackery really
>doesn't cut it, because the name int64_t will be unknown anyway and
>thus, the program using it (although in some non-instantiated template)
>will not compile. I think we need some preprocessor logic for that, and
>*please* a bit less polluting than #include <limits.h> and checking
>ULONG_LONG_MAX for some magic value.
<

Rather than adding boost specific macros, there are already appropriate
macros defined for stdint.h which haven't made it into the boost
implementation. For example we could just test for the presence of
INT64_MAX to see if int64_t is present. I appreciate that there are
potential problems with maco redefinitions if these constants are also
defined by the underlying implementation, and that macros are not everyones
favorite C++ feature <g>, but if we're going to define a macro, then why
not make it a standard one?

- John.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk