Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-03-09 17:33:13

Ahh, I've now gotten to your documentation and see you do have the
requirements of the "RealType" listed, so my quibble reduces to just
the name choice :) How about ArithmeticType or NumericType?
Or maybe just use T.

jsiek_at_[hidden] writes:
> Small nit-pick: you use the name "RealType" for the template
> argument. Actually, this could be a complex type or even another
> interval type (intervals of intervals have some interesting
> properties). Anyways, it might be good to define the actual
> requirements, and choose an appropriate name for the concept (set of
> requirements).
> Cheers,
> Jeremy
> ------------------------------------------------------------------------
> *** Got Questions? Get Answers. Got Answers? Get Paid. ***
> Sign up at and you can win $30,000 cash or a trip to China.
> -- Talk to your group with your own voice!
> --

Boost list run by bdawes at, gregod at, cpdaniel at, john at