From: Beman Dawes (beman_at_[hidden])
Date: 2000-07-28 10:05:54
Nathan Myers wrote:
>To choose a name, we should consider how it will be perceived by
>people trying to read unfamiliar code. Maybe they just encountered
>"boost::" and haven't memorized everything in it yet. How can we
Good point. Exactly.
>Something that implies a "fait accompli" would be better, implying a
>static condition rather than an action to perform. Then, we can
>consider "checked" "proven", "verified", "known", "required". However,
>grammatical correctness is why "assert" works so well, and none of
>these last satisfy it.
Action sounds better to me. How about "verify"?
>A side issue... it appears to me that the proposed expression would
>not be appropriate for use in header files. Am I right?
Sorry to be dense. I'm not seeing the issue. Could you explain?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk